nerd-fonts-hack/PKGBUILD

44 lines
2.7 KiB
Bash

# Maintainer: Yiyang Kang <kkyy%40kkyy.me>
# The fonts in this package was patched with '--careful' option.
pkgname=ttf-hack-nerd
epoch=1
pkgver=3.2.1
pkgrel=2
pkgdesc="Patched font Hack from the nerd-fonts library"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
license=('MIT')
depends=('fontconfig')
provides=('ttf-font-nerd')
conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
_commit=501d5f7f0da7e1513813276afabf60eae2e365eb
source=(
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFont-Bold.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFont-BoldItalic.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFont-Italic.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFont-Regular.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFontMono-Bold.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFontMono-BoldItalic.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFontMono-Italic.ttf"
"https://git.gensokyo.cafe/kkyy/nerd-fonts-patched-fonts/raw/commit/$_commit/Hack/HackNerdFontMono-Regular.ttf"
"${url}/raw/v$pkgver/LICENSE"
)
b2sums=(
'306565ad59bcc44717e4c2ca8891fbcad8c5db299b0245c59da9d39063c8606634f81ffaf48801d5bf3911b8947dbea941ddab2632ca3942056495bdc53d7a6f'
'9e8fb9f36657dff7c13be8fc6e3ccfc6cf75af0e22c4590536ae36a8f587b07128133cededeff843e7918109190fdf1f6af3fd7eaca255682615f5bc78a7483f'
'9bfee2df5ffb2f24451934dd58fd61fce816567e428505580cf217779841c4dd0b8df483acfad6fd1b39a02061bf518d0e71b648508550c3b4a07ce460d5e5a9'
'5b0cbe59423e322d01a1031b3b3350617ef409112f54c213c511f9b96b695ce7a01def128e7dd1b6473e510cc7c259b0f0ae6760d75848b39ec5fc0dd46b148d'
'10187b94385d046a885be5cff904e15f7460522ba62fbf9272a991479a3cbfc26d7cc794189e8b0954e736f8a538d3268236050b66423741376cdc98d1a2bec8'
'6c7904a700e2c2f10b1ce1a3c47da9193a6947576743125e13429478c6495baa73ed03afef834cf0b861c655e14b96a45c89ebd498be09d0a8d278d1e7f45d6f'
'ffbeccdeb37fc3c667033da7f5f703728605e935b641296427d4af2ace793f8d20a2411ef92bf2e0a33df0ba51bf324d1499a4b5b107613c337763ea59367285'
'9dfb29b8e1341c976c49931c03a7aedd0dfea8364f2de11069f4e82af1297afd9629dd2c968c1f1b9e2d22f41617f6c3e358ab7074d4f654a4c019c638035d45'
'ece38b21e41c31a10260b2a99ea23661a945c11b5edbcb625b0e317be59050cc3bc04d72d4b36f94d89c263fd742d31b55f449057ad54a7e912cd1b472a38a84'
)
package() {
find . -iname "*.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}