addpkg: audacity-git

This commit is contained in:
proudzhu 2015-11-03 00:12:10 +08:00
commit 8b854c091f
4 changed files with 125 additions and 0 deletions

34
.SRCINFO Normal file
View File

@ -0,0 +1,34 @@
pkgbase = audacity-git
pkgdesc = A program that lets you manipulate digital audio waveforms
pkgver = wx3.stable.r418.g162392e
pkgrel = 1
url = http://audacity.sourceforge.net/
install = audacity.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = python2
makedepends = twolame
depends = libmad
depends = libid3tag
depends = wxgtk
depends = lame
depends = lilv
depends = soundtouch
depends = ffmpeg
depends = vamp-plugin-sdk
depends = sbsms
depends = portsmf
depends = desktop-file-utils
depends = webkitgtk2
provides = audacity
conflicts = audacity
options = !makeflags
source = audacity::git+file:///home/proudzhu/workspace/audacity
source = audacity-ffmpeg.patch
sha1sums = SKIP
sha1sums = 5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61
pkgname = audacity-git

48
PKGBUILD Normal file
View File

@ -0,0 +1,48 @@
# $Id: PKGBUILD 236317 2015-04-12 19:26:30Z eric $
# Maintainer: Proudzhu <proudzhu.fdu at gmail.com>
# Contributor: Eric Bélanger <eric@archlinux.org>
pkgname=audacity-git
_pkgname=audacity
pkgver=wx3.stable.r418.g162392e
pkgrel=1
pkgdesc="A program that lets you manipulate digital audio waveforms"
arch=('i686' 'x86_64')
url="http://audacity.sourceforge.net/"
license=('GPL')
depends=('libmad' 'libid3tag' 'wxgtk' 'lame' 'lilv' 'soundtouch'
'ffmpeg' 'vamp-plugin-sdk' 'sbsms' 'portsmf' 'desktop-file-utils'
'webkitgtk2')
makedepends=('cmake' 'python2' 'twolame')
options=('!makeflags')
install=audacity.install
provides=('audacity')
conflicts=('audacity')
source=("$_pkgname::git+file:///home/proudzhu/workspace/audacity"
'audacity-ffmpeg.patch')
sha1sums=('SKIP'
'5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61')
pkgver() {
cd "$srcdir/$_pkgname"
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/^v//' | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
prepare() {
cd "$srcdir/$_pkgname"
patch -p1 -i "${srcdir}/audacity-ffmpeg.patch"
}
build() {
cd "$srcdir/$_pkgname"
./configure --prefix=/usr --with-libsamplerate
make
}
package() {
cd "$srcdir/$_pkgname"
make DESTDIR="${pkgdir}" install
}

30
audacity-ffmpeg.patch Normal file
View File

@ -0,0 +1,30 @@
diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
--- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
@@ -688,7 +688,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
- (AVOutputFormat *f),
+ (const AVOutputFormat *f),
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
@@ -755,7 +755,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
- (AVFifoBuffer *f),
+ (const AVFifoBuffer *f),
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
@@ -801,7 +801,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,
- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
(m, key, prev, flags)
);
FFMPEG_FUNCTION_WITH_RETURN(

13
audacity.install Normal file
View File

@ -0,0 +1,13 @@
post_install() {
update-desktop-database -q
update-mime-database usr/share/mime &> /dev/null
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}