update build, still room for improvements

This commit is contained in:
FabioLolix 2021-05-22 20:08:24 +02:00
parent 724a5d1203
commit 6e7e5f5436
3 changed files with 55 additions and 159 deletions

View File

@ -1,65 +1,46 @@
pkgbase = audacity-git
pkgdesc = A program that lets you manipulate digital audio waveforms
pkgver = 2.4.2.r0.g16d52f63a
pkgrel = 2
url = http://www.audacityteam.org/
pkgver = 3.0.2.r126.g90903d237
pkgrel = 1
url = https://www.audacityteam.org/
arch = i686
arch = x86_64
license = GPL
makedepends = alsa-lib
makedepends = clang
makedepends = cmake
makedepends = ffmpeg
makedepends = flac
groups = pro-audio
license = GPL2
license = CCPL
makedepends = git
makedepends = glib2
makedepends = gtk3
makedepends = cmake
makedepends = clang
makedepends = sdl2
makedepends = libsoup
makedepends = libnotify
makedepends = gstreamer
makedepends = gst-plugins-bad-libs
makedepends = ffmpeg
makedepends = jack
makedepends = lame
makedepends = libid3tag
makedepends = libogg
makedepends = libsndfile
makedepends = libvorbis
makedepends = lilv
makedepends = lv2
makedepends = portsmf
makedepends = suil
makedepends = twolame
makedepends = vamp-plugin-sdk
makedepends = nasm
depends = alsa-lib
depends = libx11
depends = gtk3
depends = expat
depends = gcc-libs
depends = gdk-pixbuf2
depends = glibc
depends = libid3tag
depends = libogg
depends = libsndfile
depends = libvorbis
depends = lilv
depends = lv2
depends = portsmf
depends = suil
depends = libmad
depends = libFLAC++.so
depends = libFLAC.so
depends = libasound.so
depends = libgdk-3.so
depends = twolame
depends = vamp-plugin-sdk
depends = libsoxr
depends = soundtouch
depends = wxgtk3
depends = libglib-2.0.so
depends = libgobject-2.0.so
depends = libgtk-3.so
depends = libid3tag.so
depends = libjack.so
depends = liblilv-0.so
depends = libogg.so
depends = libportSMF.so
depends = libsndfile.so
depends = libsuil-0.so
depends = libtwolame.so
depends = libvamp-hostsdk.so
depends = libvorbis.so
depends = libvorbisenc.so
depends = libvorbisfile.so
depends = wxgtk2
optdepends = ffmpeg: additional import/export capabilities
optdepends = audacity-extras: nyquist plugins for audacity
provides = audacity
conflicts = audacity
source = audacity::git+https://github.com/audacity/audacity.git
sha1sums = SKIP
source = git+https://github.com/audacity/audacity.git
sha256sums = SKIP
pkgname = audacity-git

105
PKGBUILD
View File

@ -1,101 +1,46 @@
# Maintainer: Bernhard Landauer <oberon@manjaro.org>
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Bernhard Landauer <oberon@manjaro.org>
# Contributor: Eric Bélanger <eric@archlinux.org>
_pkgname=audacity
pkgname=$_pkgname-git
pkgver=2.4.2.r0.g16d52f63a
pkgrel=2
pkgname=audacity-git
pkgver=3.0.2.r126.g90903d237
pkgrel=1
pkgdesc="A program that lets you manipulate digital audio waveforms"
arch=('i686' 'x86_64')
url="http://www.audacityteam.org/"
license=('GPL')
depends=('expat'
'gcc-libs'
'gdk-pixbuf2'
'glibc'
'libmad'
'libFLAC++.so'
'libFLAC.so'
'libasound.so'
'libgdk-3.so'
'libsoxr'
'soundtouch'
'wxgtk3'
'libglib-2.0.so'
'libgobject-2.0.so'
'libgtk-3.so'
'libid3tag.so'
'libjack.so'
'liblilv-0.so'
'libogg.so'
'libportSMF.so'
'libsndfile.so'
'libsuil-0.so'
'libtwolame.so'
'libvamp-hostsdk.so'
'libvorbis.so'
'libvorbisenc.so'
'libvorbisfile.so'
'wxgtk2')
makedepends=('alsa-lib'
'clang'
'cmake'
'ffmpeg'
'flac'
'git'
'glib2'
'gtk3'
'jack'
'lame'
'libid3tag'
'libogg'
'libsndfile'
'libvorbis'
'lilv'
'lv2'
'portsmf'
'suil'
'twolame'
'vamp-plugin-sdk')
optdepends=('ffmpeg: additional import/export capabilities'
'audacity-extras: nyquist plugins for audacity')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+https://github.com/$_pkgname/$_pkgname.git")
sha1sums=('SKIP')
arch=(i686 x86_64)
url="https://www.audacityteam.org/"
license=(GPL2 CCPL)
groups=(pro-audio)
depends=(alsa-lib libx11 gtk3 expat libid3tag libogg libsndfile
libvorbis lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr soundtouch)
makedepends=(git cmake clang sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs
ffmpeg jack nasm)
# can't find system lame portmidi
optdepends=('ffmpeg: additional import/export capabilities')
provides=(audacity)
conflicts=(audacity)
source=("git+https://github.com/audacity/audacity.git")
sha256sums=('SKIP')
pkgver() {
cd $_pkgname
cd audacity
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -d'.' -f2-
}
build() {
mkdir $_pkgname/build
cd $_pkgname/build
mkdir audacity/build
cd audacity/build
CC=clang cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
audacity_use_sndfile:STRING=system \
-DwxBUILD_TOOLKIT:STRING=gtk3 \
-Daudacity_use_wxwidgets=local \
audacity_use_ffmpeg:STRING=loaded \
audacity_use_expat:STRING=system \
audacity_use_lame:STRING=local \
audacity_use_portaudio:STRING=local \
audacity_use_midi:STRING=local \
audacity_use_flac:STRING=system \
audacity_use_id3tag:STRING=system \
audacity_use_sbsms:STRING=local \
audacity_use_soundtouch:STRING=system \
audacity_use_twolame:STRING=system \
audacity_use_vorbis:STRING=system \
audacity_use_lv2:STRING=local \
..
cmake --build .
make .
}
package() {
cd $_pkgname/build
cd audacity/build
make DESTDIR="${pkgdir}" install
cd ..
install -vDm 644 plug-ins/*.ny -t "${pkgdir}/usr/share/${pkgname}/plug-ins"
}

View File

@ -1,30 +0,0 @@
diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
--- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
@@ -688,7 +688,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
- (AVOutputFormat *f),
+ (const AVOutputFormat *f),
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
@@ -755,7 +755,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
- (AVFifoBuffer *f),
+ (const AVFifoBuffer *f),
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
@@ -801,7 +801,7 @@
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,
- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
(m, key, prev, flags)
);
FFMPEG_FUNCTION_WITH_RETURN(