patch portaudio-v19 so clang can compile it
This commit is contained in:
parent
05e6b78f2a
commit
599315c20a
5
.SRCINFO
5
.SRCINFO
|
@ -1,6 +1,6 @@
|
||||||
pkgbase = audacity-git
|
pkgbase = audacity-git
|
||||||
pkgdesc = A program that lets you manipulate digital audio waveforms
|
pkgdesc = A program that lets you manipulate digital audio waveforms
|
||||||
pkgver = 3.0.2.r299.ge6e81399f
|
pkgver = 3.0.2.r317.g3ebd8d401
|
||||||
pkgrel = 1
|
pkgrel = 1
|
||||||
url = https://www.audacityteam.org/
|
url = https://www.audacityteam.org/
|
||||||
arch = i686
|
arch = i686
|
||||||
|
@ -41,7 +41,8 @@ pkgbase = audacity-git
|
||||||
provides = audacity
|
provides = audacity
|
||||||
conflicts = audacity
|
conflicts = audacity
|
||||||
source = git+https://github.com/audacity/audacity.git
|
source = git+https://github.com/audacity/audacity.git
|
||||||
|
source = audacity.patch
|
||||||
sha256sums = SKIP
|
sha256sums = SKIP
|
||||||
|
sha256sums = c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96
|
||||||
|
|
||||||
pkgname = audacity-git
|
pkgname = audacity-git
|
||||||
|
|
||||||
|
|
15
PKGBUILD
15
PKGBUILD
|
@ -1,9 +1,10 @@
|
||||||
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
|
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
|
||||||
|
# Maintainer: Ong Yong Xin <ongyongxin2020+github AT gmail DOT com>
|
||||||
# Contributor: Bernhard Landauer <oberon@manjaro.org>
|
# Contributor: Bernhard Landauer <oberon@manjaro.org>
|
||||||
# Contributor: Eric Bélanger <eric@archlinux.org>
|
# Contributor: Eric Bélanger <eric@archlinux.org>
|
||||||
|
|
||||||
pkgname=audacity-git
|
pkgname=audacity-git
|
||||||
pkgver=3.0.2.r299.ge6e81399f
|
pkgver=3.0.2.r317.g3ebd8d401
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="A program that lets you manipulate digital audio waveforms"
|
pkgdesc="A program that lets you manipulate digital audio waveforms"
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
|
@ -18,14 +19,22 @@ makedepends=(git cmake clang sdl2 libsoup libnotify gstreamer gst-plugins-bad-li
|
||||||
optdepends=('ffmpeg: additional import/export capabilities')
|
optdepends=('ffmpeg: additional import/export capabilities')
|
||||||
provides=(audacity)
|
provides=(audacity)
|
||||||
conflicts=(audacity)
|
conflicts=(audacity)
|
||||||
source=("git+https://github.com/audacity/audacity.git")
|
source=(
|
||||||
sha256sums=('SKIP')
|
"git+https://github.com/audacity/audacity.git"
|
||||||
|
"audacity.patch"
|
||||||
|
)
|
||||||
|
sha256sums=('SKIP' 'c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd audacity
|
cd audacity
|
||||||
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -d'.' -f2-
|
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -d'.' -f2-
|
||||||
}
|
}
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd audacity
|
||||||
|
patch --forward --strip=1 --input="${srcdir}/audacity.patch"
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
mkdir audacity/build
|
mkdir audacity/build
|
||||||
cd audacity/build
|
cd audacity/build
|
||||||
|
|
|
@ -0,0 +1,17 @@
|
||||||
|
diff --unified --recursive --text audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c
|
||||||
|
--- audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:17:06.606660728 +0800
|
||||||
|
+++ audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:18:22.376662323 +0800
|
||||||
|
@@ -4363,11 +4363,12 @@
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ pthread_cleanup_pop( 1 );
|
||||||
|
|
||||||
|
end:
|
||||||
|
; /* Hack to fix "label at end of compound statement" error caused by pthread_cleanup_pop(1) macro. */
|
||||||
|
/* Match pthread_cleanup_push */
|
||||||
|
- pthread_cleanup_pop( 1 );
|
||||||
|
|
||||||
|
PA_DEBUG(( "%s: Thread %d exiting\n ", __FUNCTION__, pthread_self() ));
|
||||||
|
PaUnixThreading_EXIT( result );
|
Loading…
Reference in New Issue